For the complete documentation index, see llms.txt. This page is also available as Markdown.

erreur "Invalid input" lors de la mise à jour d'un Community Template

Description du problème

Lors de la mise à jour d'un Community Template depuis la Gallery GTM, il est possible de rencontrer l'erreur suivante :

Invalid input

Cette erreur s'affiche au moment d'accepter la mise à jour dans la modale "Changes" et empêche l'application de la nouvelle version du template.

⚠️ Ce bug est générique à GTM et peut affecter n'importe quel Community Template disposant d'une mise à jour disponible depuis la Gallery.


Symptômes

  • En cliquant sur "View update" puis en tentant d'accepter les changements, le message Invalid input apparaît en bas de l'écran

  • Aucun champ n'est mis en évidence en rouge dans le tag correspondant

  • Le tag continue de fonctionner normalement avec l'ancienne version


Cause

Il s'agit d'un bug connu de l'interface GTM. Le mécanisme de migration des tags existants lors d'une mise à jour de Community Template depuis la Gallery échoue dans certaines conditions, indépendamment de la configuration du tag ou du contenu du template.


Workaround

En attendant un correctif de Google, voici la procédure pour contourner le problème :

  1. Aller dans Templates → sélectionner le template concerné

  2. Ouvrir le template en mode édition (icône crayon)

  3. Dans l'onglet Info, renommer le template en ajoutant un préfixe ou suffixe (ex: A - ABconsent (Sirdata CMP) | Google Consent Mode)

  4. GTM affiche une modale demandant de confirmer la création d'une variante locale

  5. Vous pouvez désormais accepter la mise à jours

ℹ️ Note : cette procédure désolidarise définitivement le template renommé de la Gallery. Il ne recevra plus de mises à jour automatiques. Le nouveau template importé sera lui correctement lié à la Gallery pour les futures mises à jour

Ce bug a été remonté à Google.

Mis à jour

Ce contenu vous a-t-il été utile ?